Resolved
This incident has been resolved
Monitoring
We have identified that data residency information was missing for the Power BI Connectors integration, which may have caused issues for some customers. A fix has been applied, and we are currently monitoring the results.